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Blender - Download
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Step 1: Download Blender
https://www.blender.org/



Blender - Download
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The Freedom to Create

== Download Blender 3.3

macO0S, Linux, and other versions

Fully Featured Free & Open Source Be

Whether you do animation, modeling, Free to Use. Free to Share. Free to Blender's main strength is its huge
VFX, games, you name it. Change. Free to Sell Your Work. community. Made by hundreds of
Blender's got you covered. Blender is Free Software. contributors from around the world.

Check out the features > Learn more about the license > Get involved >

What's New

A new hair grooming system, procedural UV unwrapping,
Library Overrides improvements and so much more.

115.4 blender-3.3.0-win...msi
" 2.9/231 MB. 9 mins left

Show all X

Step 1: Download Blender
https://www.blender.org/



Blender GIS - Download

S Y & github.com/domlysz/BlenderGIS

O Product ~ Solutions Open Source ~ Pricing Sign in ‘ Sign up ‘

g dom|ySZ/B|enderG|S Public .g Notifications % Fork 1k 7 Star 5.6k -

<> Code (O Issues 154 19 Pullrequests 12 &Y Discussions () Actions [ Projects [0 wiki @ Security |2 Insights

¥ master ~ ¥ 2 branches © 15 tags Go to file m About

Blender addons to make the bridge

3 domlysz bump version 7acdaae on 31 May YD) 489 commits between Blender and geographic data
M clients add small basemaps qt client (wip) 4 years ago Ay @) Uy
openstreetmap geospatial gis
I core Improve query performance. 17 months ago
geodata raster shapefile
BB icons add earth sphere utilities 3 years ago georeferencing aen 3d
W operators Remove deprecated argument 'deform’ 4 months ago R i)
importexport terrain-model basemap
B .gitignore add gitignore and license 4 years ago
3d-map
[ LICENSE add gitignore and license 4 years ago
[ Readme
README.md update readme min version 4 months ago
O P g &3 GPL-3.0 license
3 _init_py bump version 4 months ago % 5.6k stars
[ geoscenepy Minor fix (proposal) on line 48 3 years ago © 240 watching
] ‘ % 1k forks
[§ issue_template.md update issue template 3 years ago
3 prefspy add opentopography.org api key to settings 7 months ago
Releases 3
‘= README.md © v2.2.8 (Latest)
on 31 May

Blender GIS + 2 releases

Blender minimum version required : v2.83

Packages
Note : Since 2022, the OpenTopography web service requires an API key. Please register to opentopography.org and No packages published
request a key. This service is still free.
Wiki - FAQ - Quick start guide - Flowchart Contributors 13

E D@D

+ 2 contributors

Functionalities overview

GIS datafile import : Import in Blender most commons GIS data format : Shapefile vector, raster image, geotiff DEM,
OpenStreetMap xml.

There are a lot of possibilities to create a 3D terrain from geographic data with BlenderGIS, check the Flowchart to
have an overview. Languages

Exemple : import vector contour lines, create faces by triangulation and put a topographic raster texture. ® Python 100.0%

Step 2: Download BlenderGIS & download code as ZIP (don’t unpack)
https://github.com/domlysz/BlenderGIS



Installing BlenderGIS to Blender
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Step 3: Open Blender + Create a new project + Go to Edit > Preferences > Add-ons > Install > Find “BlenderGIlS-master.zip (wherever you downloaded it) > Install Add-on > Tick
the box stating: “3D View: BlenderGIS” to enable BlenderGIS.




Installing BlenderGIS to Blender
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> Import-Export: BioVision Motion Capture (BVH) format

> Import-Export: FBX format

Step 3: Open Blender + Create a new project + Go to Edit > Preferences > Add-ons > Install > Find “BlenderGIlS-master.zip (wherever you downloaded it) > Install Add-on > Tick
the box stating: “3D View: BlenderGIS” to enable BlenderGIS.



Installing BlenderGIS to Blender
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Step 3: Open Blender + Create a new project + Go to Edit > Preferences > Add-ons > Install > Find “BlenderGIlS-master.zip (wherever you downloaded it) > Install Add-on > Tick
the box stating: “3D View: BlenderGIS” to enable BlenderGIS.




Installing BlenderGIS to Blender
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Step 3: Open Blender + Create a new project + Go to Edit > Preferences > Add-ons > Install > Find “BlenderGIlS-master.zip (wherever you downloaded it) > Install Add-on > Tick
the box stating: “3D View: BlenderGIS” to enable BlenderGIS.




Installing BlenderGIS to Blender

A% Blender Preferences
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Step 3: Open Blender + Create a new project + Go to Edit > Preferences > Add-ons > Install > Find “BlenderGIlS-master.zip (wherever you downloaded it) > Install Add-on > Tick
the box stating: “3D View: BlenderGIS” to enable BlenderGIS.




BlenderGIS - Generating Basemap
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Step 4: To create your site, you need to go to GIS > Web geodata > Basemap




BlenderGIS - Generating Basemap
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Step 5: A basemap Ul should pop up and all you have to do is make sure the source is google and the layer is satellite, if so press OK.




BlenderGIS - Generating Basemap

The University of Auckland
Zoom level

oK

Step 6: It'll give you a new Ul and a satellite view of the whole earth will pop up. Press “G” to go to basemap (basically making you go to a destination), type in your site - for exam-
ple “The University of Auckland”. After that, your zoom by default is at 0, the bigger the number - the closer it is to your site. | normally recommend 13-15. Once everything is setted
up, press OK.




BlenderGIS - Generated Basemap
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Step 7: It'll give you a closer shot of your site, to capture/grab what's on screen press “E” and it should crop it to your viewport screen ratio.




OpenTopography - Generating API key
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- C (O @& opentopography.org

Getting Started MyOpenTopo Partner With Us Search OpenTopography...

AV

e %« 0@

X

Ope nTo pog raphy HOME  DATA RESOURCES LEARN ABOUT
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Latest News

New NCALM dataset over the South Padre Island, TX available

Sep 11,2022
A new lidar dataset covering 61 km2 over Padre Island, TX is now available on OpenTopography. This lidar dataset was collected by
the National Center for Airborne Laser Mapping (NCALM) as...

Land Information New Zealand (LINZ) West Coast dataset expanded along west coast of South
Island, NZ

Aug 31,2022
OpenTopography has updated the LINZ dataset over Westport, New Zealand with new data that now covers over 6000 km2 along
the west coast of the South Island. This collection is part of the South Island, West Coast regional lidar survey, and is the...

OpenTopography at the 2022 AGIC Education and Training Symposium

Aug 29,2022
OpenTopography will be at the Arizona Geographic Information Council (AGIC) Education and Training Symposium in Prescott, AZ
this week. Be sure...

More news

Latest Blog Posts

New package automates river relative elevation model (REM) generation

Request an API Key

Latest Datasets:
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Vulnerahility, TX 2021
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Step 8: Before we make our site contours, you need to generate an APl Key. To generate one, you need to create an account with OpenTopography (opentopography.org). Create

an account and request for an APl Key.

15



OpenTopography - Generating API key

myOpenTopo Authorizations and API Key Welcome Raphael Angelo Gannaban ( Sign Out)

Request APl Key

APl key: edd70f3361e82b632f0fe08015305122

OpenTopography's REST APl is documented using the OpenAPI specification and available via Swagger for visualizing and testing via the browser.

Request Power User

Request Dataspace User

User Access Levels

1. Guest Users:
s Access to 50 million points per point cloud & processing job
« Guests do not have access to the personalized point cloud and raster jobs interface which allows you to view all previously submitted jobs, share job results and
resubmit jobs

Q Username: rgan288@aucklanduni.ac.nz. You are logged into OpenTopography as a registered user.

2. Registered Users:
s Access to 250 million points per point cloud & processing job
e Personalized point cloud and raster jobs interface
¢ Point Cloud & Raster bulk data downloads

3. Power Users:
e Access to 500 million points per point cloud job (without DEM generation) or 350 million points per point cloud & processing job (with DEM generation). Power
User status does not apply to federated datasets (e.g. USGS 3DEP) at this time.
e Personalized point cloud and raster jobs interface
» Point Cloud & Raster bulk data downloads

Power User requires completing a simple form to explain why you feel you need elevated data access privileges.

Step 9: Once the API key is generated, copy and paste it. Go back to Blender and select GIS > Web geodata > Get Elevation (SRTM). A small Ul will pop up and say ‘server’ and
‘api key’. Paste your API key and press OK. It'll take roughly around 2-3 minutes to generate your site topography.
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Creating SRTM Data through generated API Key
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Step 9: Once the API key is generated, copy and paste it. Go back to Blender and select GIS > Web geodata > Get Elevation (SRTM). A small Ul will pop up and say ‘server’ and
‘api key’. Paste your API key and press OK. It'll take roughly around 2-3 minutes to generate your site topography.




Generating site topography
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Step 10: Once topography has been generated, next step is to generate building heights, roads, etc. Go to GIS > Web geodata > Get OSM > A new GUI will pop up and by default
it will be on ‘Nodes’ - change that to Ways and tick what you needed (Control + Shift + L click), also tick “Elevation from Object” and “Building Extrusion”, you'll be needing one for
building heights, etc. Once all is setted up, tick OK. It'll take 5-8 minutes generating the building heights, roads, etc (depending on the complexity of the site).




Generating Site Topography
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Step 10: Once topography has been generated, next step is to generate building heights, roads, etc. Go to GIS > Web geodata > Get OSM > A new GUI will pop up and by default
it will be on ‘Nodes’ - change that to Ways and tick what you needed (Control + Shift + L click), also tick “Elevation from Object” and “Building Extrusion”, you'll be needing one for
building heights, etc. Once all is setted up, tick OK. It'll take 5-8 minutes generating the building heights, roads, etc (depending on the complexity of the site).




Generating Building Heights, Highway, Waterway, etc
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Step 10: Once topography has been generated, next step is to generate building heights, roads, etc. Go to GIS > Web geodata > Get OSM > A new GUI will pop up and by default
it will be on ‘Nodes’ - change that to Ways and tick what you needed (Control + Shift + L click), also tick “Elevation from Object” and “Building Extrusion”, you'll be needing one for
building heights, etc. Once all is setted up, tick OK. It'll take 5-8 minutes generating the building heights, roads, etc (depending on the complexity of the site).
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Generated Buildings, Road + Topography (Final)
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Step 11: Once generated, double check if the buildings are in one group, same as the road, etc.

Link to YouTube tutorial in case you’re lost: https://www.youtube.com/watch?v=YNtKnmRXVIo
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BlenderGIS to Rhino
Importing Data from BlenderGIS to Rhino

Raphael Angelo Gannaban



BlenderGIS - Import from Blender to Rhino
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Step 1: Select all your model components and go to File > Export > Wavefront (.obj) - easiest export to Rhino compared to other options.




BlenderGIS - Import from Blender to Rhino
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Step 1: Select all your model components and go to File > Export > Wavefront (.obj) - easiest export to Rhino compared to other options.




BlenderGIS - Import from Blender to Rhino
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Step 2: Under “Transform” on the right hand side - change the “Up” to “Z Up”.
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BlenderGIS - Import from Blender to Rhino
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Step 3: Export OBJ and open up Rhino. Type “Import” and find the file. A new Ul will pop up and press OK and import should go smoothly.



BlenderGIS - Import from Blender to Rhino
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Step 3: Export OBJ and open up Rhino. Type “Import” and find the file. A new Ul will pop up and press OK and import should go smoothly.
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