


This is the basic architectural 
template with elevations and 
basic grids already set up.

Importing CAD

First we will start with the 
site.

To import a site contour file 
go; Insert > Import > Import 
CAD.

In the Import CAD Formats 
window select the dwg 
ile called BIM_Contour.dwg 
located in Scratch > BIM 
BOOTCAMP > BIM_Contour.

Click [Open]

The contour lines will now 
appear on the floor plan. 

Project Browser > Floor 
Plans > Level 1



Topography

Now to model the contour 
surface, it is easiest to work 
from the 3d view. Navigate 
in the Project Browser > 3D 
Views > Work.

Go too; Massing & Site > 
Model Site > Toposurface.

Now in the green temporary 
banner go; Modify | Edit 
Surface > Tools > Create 
from Import > Select Import 
Instance.

Select the dwg file.

In the Add Points from 
Selected Layers dialog 
insure all layers are checked 
and Click [OK]



To finish the site surface 
select Modify | Edit Surface 
> Surface > Finish Surface.

Levels

Now to sort out the floor 
levels before modeling it 
is easiest done through 
a elevation. Navigate too 
Project Browser > Elevation 
(Building Elevation) > 
South.

Go too; Architecture > 
Datum > Level, and draw 
two new levels above Level 
2.

Once drawn the distance 
between the levels can 
be modified by selecting 
the level to be shifted. 
Using the temporary blue 
dimension input the values 
as shown. 2200 for Level 2 
and 3000 for the other two 
levels.



The top Level may move 
out of the crop region. The 
crop can be adjusted by 
selecting the crop box and 
moving the blue nodes.

The levels are complete. 

(Level 2 becomes the 
ground floor. You may 
rename these levels in the 
Project Browser to make it 
easier to navigate.)

Grids

To aid with modeling we 
will now set up the grids.

First Navigate to the 
Ground Floor; Project 
Browser > Floor Plans > 
Level 2.

Go too; Architecture > 
Datum > Grids

Using the grids from the 
template draw three more 
vertical and one horizontal 
grids with the dimensions 
as shown. 

Move the grids by using the 
temporary blue dimensions 
to input the required 
values.



Wall

To model the walls go to 
Architecture > Build > Wall.

In Properties > Basic Wall 
select an appropriate wall 
(e.g. 90T_40Cld_13Gb)

Set the wall height to Level 
3 under; Modify | Place Wall 
> Height > Level 3.

The method for drawing 
a wall can be adjusted 
at; Modify | Place Wall > 
Location Line. For this 
purpose select Finish Face: 
Exterior

Draw the walls onto the 
grids 1, 3, 5, and A as 
shown.

Add interior walls as you 
wish. Select an appropriate 
interior wall type under 
Properties > Basic Wall.

Note: the walls can be 
modified further under 
Properties > Edit Type.



Ground Slab

To make the ground floor 
slab go too; Massing & Site 
> Model Site > Building 
Pad.

To draw the boundary  
select the pick line method. 
Modify | Create Pad 
Boundary > Draw > Pick 
Lines.

Note: the pad can be 
modified further under 
Properties > Edit Type.

Click on the exterior side 
of the exterior walls. A pink 
line will appear.

To finish select Modify | 
Create Pad Boundary > 
Mode > Finish Edit Mode.

Optional: each time you 
draw a line you can click the 
lock to link the edge of the 
slab to the walls.



To draw the floor plan 
on Level 3 Navigate too; 
Project Browser > Floor 
Plans > Level 3.

As for the Level 2 floor 
plan, select appropriate 
wall type, wall height too 
Level 4 and Location Line.

Draw the walls onto the 
grids 1, 4, 5, and A as 
shown.

Floor

To model the floor on Level 
3 go too; Architecture > 
Build > Floor.

In Properties > Floor Select 
an appropriate floor type 
(e.g. 250T_19PBd).

To draw the boundary  
select the pick line method. 
Modify | Create Floor 
Boundary > Draw > Pick 
Lines.



Click on the exterior side 
of the exterior walls, a pick 
line for the boundary will 
appear.

To finish select Modify | 
Create Floor Boundary > 
Mode > Finish Edit Mode.

Note: the floor can be 
modified further under 
Properties > Edit Type.

A Revit dialog box will 
appear asking ‘Would you 
like walls that go up this 
floor’s level to attach to it’s 
bottom?’ Click [Yes].

Roof

To model the roof go too; 
Architecture > Build > Roof 
> Roof by Footprint.



In Properties > Basic Roof 
Select an appropriate floor 
type (e.g. 150T_50Pur_
CGI).

To draw the boundary  
select the line method. 
Modify | Create Floor 
Boundary > Draw > Line.

To set the height of the roof 
set the base level at Level 
4. Properties > Constraints 
> Base Level > Level 4.

Note: the roof can be 
modified further under 
Properties > Edit Type.

Draw a boundary profile to 
your desire.

To adjust the roof 
overhangs. Select the line 
to be shifted and use the 
blue temporary dimensions 
to make adjustments.



To create a pitched roof 
select one of the boundary 
lines check Properties > 
Constraints > Defines Roof 
Slope.

Adjust pitch to 5 degrees in 
Properties > Constraints > 
Dimensions > Slope.

Note: by selecting more 
then one boundary line 
you can create hipped and 
gable roofs.

Navigate to the 3D View. 
Project Browser > 3D 
Views > Work.

To close the gap between 
the wall and roof select all 
the Level 3 wall and select 
Modify | Walls > Modify 
Wall > Attach Top/Base.

Select the roof, the gap will 
then be closed



Curtain Wall

To create a curtain wall 
select the front wall. Under 
Properties select a curtain 
wall.

Note: Scroll down to the 
bottom of the wall types.

Curtain Grid

First add a curtain grid to 
the curtain wall. Go too; 
Architecture > Build > 
Curtain Grid.

Add a grid as desired by 
clicking on the edge of the 
curtain wall panel.



Mullions

To add mullions to the 
curtain wall go too; 
Architecture > Build > 
Mullion.

In Properties select an 
appropriate mullion type 
(e.g. Rectangular Mullion > 
50 x 150mm).

The placement method 
of the mullions can be 
selected from Modify | 
Place Mullion > Placement.

Click on the grid lines and 
mullions will be added to 
the curtain wall.

Note: the mullions can 
be modified further under 
Properties > Edit Type.



Window

To add standard windows 
start from Architecture > 
Build > Window. 

To place a window 1200 x 
600 select the closed sized 
window from Properties, 
(e.g. FL 1 Aluminum-
Grooved (NZ) > 1000 x 
600).

First adjust the head height 
to 2000 under Properties > 
Other > Head Height.

To adjust size go too; 
Properties > Edit Type. 

In Type Properties dialog 
click [Duplicate...]

In Name dialog call window 
‘1200 x 600’. Click [OK]



Adjust height and width 
in Type Properties dialog 
under Dimension > Height 
and Width.

Click [OK].

Click on the exterior side 
of the walls to place the 
windows.

Use the temporary blue 
dimensions to adjust the 
location.

Door

To add a entrance door 
navigate to Project Browser 
> Floor Plans > Level 2.

For door go too; 
Architecture > Build > Door.



In Properties select an 
appropriate exterior door 
type (e.g. Ext Single Out-
Aluminium_Grooved (NZ) > 
910 x 2030).

Click on the side of the wall 
you wish the door to swing 
from.

The door can be flipped 
later by selecting the door 
and using the flip handles 
as highlighted.

Note: the door can be 
modified further under 
Properties > Edit Type.

In order to add a row of 
columns for the cantilever 
add grid lines as shown. 
Architecture > Datum > 
Grid.



Column

To model the columns go 
too; Architecture > Build 
> Column > Column: 
Architectural.

In Properties select an 
appropriate column type 
(e.g. Column-Rectangular 
(NZ) > 300 x 300mm).

Set the height to Level 3; 
Modify | Place Column > 
Height > Level 3.

To place the columns, click 
at the intersection of the 
two grid lines.

Note: the column can be 
modified further under 
Properties > Edit Type.



Layout Sheet

Modify the drawing scale 
to 1:100 as shown for floor 
plans Level 2 and Level 3.

Note: feel free to adjust 
to suitable scales here 
in order to fit on the 
layout sheet for all plans, 
elevations, etc.

The drawing will be too 
large for the layout to we 
need to crop out the site. 
Click Show Crop Region 
and Crop View as circle.

Select the crop region and 
resize to the floor plan

Optional: to tidy up later the 
crop region can be hidden 
to remove the frame.

To start laying out your 
drawing navigate to the 
drawing sheets. Project 
Browser > Sheets (all) > 
A101 - Unnamed.

Select the title block select 
Properties > Edit Type.

In Type Properties click 
[Load]. In Open search 
Architecture > Annotations 
> Title Blocks > Titleblock 
A1 metric (NZ). Click 
[Open]. Then Type 
Properties > [OK]



To place drawing to layout 
select it in the Project 
Browser an drag it in the 
sheet.

For This tutorial you are to 
create a single A1 sheet 
containing:
2 Floor Plans
4 Elevations
1 Section
3D View (sectional)

Elevations

Open Elevations, set scale 
to 1:200 as shown.

The Crop region may need 
to be adjusted to fit in the 
building as well

Feel free to adjust the 
visual style as shown. 
Shaded view has been 
selected here.

Drag these to the layout 
sheet. Project Browser 
> Sheets (all) > A101 - 
Unnamed.



Section

To create a section 
navigate to Level 2. Project 
Browser > Floor Plans > 
Level 2.

For section go too; View >  
Create > Section. 

Draw section line through 
desired part of the building. 

Navigate to the section 
drawing. Project Browser > 
Section (Building Elevation) 
> Section 1.

Adjust the scale to 1:200 
as shown.

Hide Crop Region.

Drag to the layout sheet. 
Project Browser > Sheets 
(all) > A101 - Unnamed.



3D Section

To create 3D section select 
to Project Browser > 3D 
Views > Work > (Right 
click) Duplicate View > 
Duplicate.

Rename new 3D view to 
‘3D Section’.

Under Properties > Extents 
check Section Box.

Select the section box and 
move the nodes to produce 
the desired.

With the section box 
selected right click and 
select Hide in View > 
Elements to hide the box.

Drag 3D Section into the 
layout sheet.



Exploded Axonometry

Exploded Axonometry are 
created similarly to a 3D 
section with the section 
box.

Create two new 3D views 
for the top and bottom 
floor Project Browser > 
3D Views > Work > (Right 
click) Duplicate View > 
Duplicate.

Rename ‘3D axo 1 and 3D 
axo 2’.

Hide section box; right click 
and select Hide in View > 
Elements to hide the box.

Turn off contours; View 
> Visibility/Graphics 
and uncheck Visibility > 
Topography.

You may have to hide the 
dwg contours.

Change the view type to 
Hidden Line as shown.

Do this process to the 
upper floor and drag to the 
layout sheet.



For the upper drawing 
select drawing and switch 
of title in the Properties 
window and select 
Viewport > No Title.

Camera

To set up a camera go 
too; View tab > 3D View > 
Camera.

Click where you want the 
camera to be, then click 
where the subject is.

The easiest way to edit a 
camera is with tiled views; 
View tab > Windows > Tile.

To show camera, right click 
the camera’ s view in the 
Project Browser and Show 
Camera. The camera will 
now appear on the floor 
plan.



Rendering

Navigate to View tab > 
Graphics > Render.

Here you can adjust the 
quality, resolution and 
lighting of the render (the 
lower the resolution the 
quicker the render).

You can save the render 
to the project, or you can 
export it as an image file. 
Rendering > Image > Save 
to Project... Or Export...

Publishing

Place all drawings to the 
layout sheet.

To print to PDF go to the 
Revit logo to the top left 
corner > Print and select a 
pdf printer
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Modeling from Mass

To create mass go 
too; Massing & Site > 
Conceptual Mass > In-
Place Mass.

Name mass as 
appropreate, Click [OK]

Choose drawing method 
under Modify | Place Lines 
> Draw and draw foot print.

Appendix



Select foot print Modify | 
Line > Select > Modify.

Create solid by going to 
Modify | Lines > Form > 
Create Form > Solid Form.

Navigate to the 3D view 
Project Browser > 3D 
Views > Work.

Start modeling the form by 
selecting the surfaces and 
edges and moving them 
around.

Complete modeling by 
selecting Modify | Lines 
> In-Place Editor > Finish 
Mass.

Navigate to a elevation 
Project Browser > 
Elevations.

Add appropriate levels to 
the building to appropreate 
floor levels between each 
floor. Architecture > Datum 
> Levels.



Navigate back to the 3D 
view Project Browser > 3D 
View > Work.

To Create internal floor 
select the mass and select; 
Modify | Mass > Model > 
Mass Floors.

In the Mass Floor window 
select the appropreate 
floors and click [OK]. 

Now to model wall, floors, 
and roofs.

Go to Architecture > Build 
> Wall > Wall by Face as 
shown and click on the 
surface in the 3D view. 
Follow this process with the 
floor and roof tool.



Importing Rhino Models

Create your rhino geometry

Make sure the geometry is 
1:1 scale and is located close 
to the model basepoint (0,0,0 
grid location)

Select the geometry and go 
to file > export selected and 
save the file as ACIS .sat file.

In Revit go to Massing & Site 
> In-Place Mass > OK

While in the Mass In-Place 
Editor go to Insert > Import 
CAD > Select the .sat file > 
Open

Your Model should now be in 
Revit and can be edited as a 
Revit Mass 

Refer to tutorial chapter: 
Modelling from Mass
for instructions on how to 
create walls, roofs, and floors 
from a mass.



Annotate Drawings

Go to the cross section created 
earlier.

Change the scale to 1:50 and the 
detail level to Fine

To insert dimensions go to the 
Annotate tab > Dimension > 
Aligned 

Click the horizontal grid lines to 
place level height dimensions.

Click the corners or faces of 
revit elements to place specific 
demensions

To insert notes go to the Annotate 
Tab > Text and then click where 
you want to place the note

To add a text leader click on the 
text and go to Modify Text Notes 
the click on one of the the add 
leader icons

The location of the leader can be 
adjusted in this tab

Click the end of the leader and 
drag it to the correct location



Detailing

Before drawing the Roof Eave 
detail we should add a gutter and 
fascia to the model.

Go to the Project Browser > Work 
View to view the model in 3D

To add the gutter and fascia to 
the roof go to the Architecture Tab 
> Roof > Fascia

Click the edge of the roof to place 
the gutter and fascia

Note; the components can be 
modified in the properties tab 
which can be accessed by 
clicking on model element

To create a detail view open the 
cross section and go to the View 
Tab > Callout and then click drag 
a window around the eave area

To access the detail view go to 
the project browser > sections > 
callout 1

Change the scale of the draw-
ing to 1:10 and turn off the view 
extent window



Detailing

To turn off the grid and level go 
to the Properties Tab > Visibility / 
Graphics Overrides > Annotation 
Categories and untick Grids and 
Levels

To lower the gutter and fascia 
below the roofing line click on 
the model elements and go to 
Properties > Vertical Profile Offset 
and enter - 40.0

To draw in a timber top plate go 
to the Annotate Tab > Detail Lines 
and draw a 90x45 rectangle in 
the framing space. 

Select the rectangle and change 
the line style to Wide Lines

Then select the Thin Lines Style 
in the drop down box and draw in 
a diagonal from corner to corner 
  



To make the top plate a Detail 
Group, select all the lines and 
go to the Annotate Tab > Detail 
group > Create Group 

Name the group 90x45

Repeat the workflow to add 
70x45 roof purlins and 150x45 
blocking between the rafters

To indicate roofing underlay and 
soffit lining go to the Annotate tab 
> Detail lines

Use the Thin Dashed Style for the 
underlay and the Thin Lines Style 
for the soffit lining

To indicate insulation go to the 
Annotate Tab > Insulation and 
draw it like a line. Change the 
width to 140 by clicking on the 
insulation and going to the prop-
erties tab

Note Line Styles can be edited 
by going to Manage > Additional 
Settings > Line Styles



To insert notes go to the Annotate 
Tab > Text and then click where 
you want to place the note

To add a text leader click on the 
text and go to Modify Text Notes 
the click on one of the the add 
leader icons

The location of the leader can be 
adjusted in this tab

Click the end of the leader and 
drag it to the correct location

To insert dimensions go to the 
Annotate tab > Dimension > 
Aligned 
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